Running the Relational Database Curriculum in your Browser

I’m stuck here… I can’t get to the next lesson… any suggestions?

Hi Guys!

I fixed it my problem, i went to the developer tools, and deleted the local storage… i reload again and now is completed. I don’t know if is the right way to do it …but at least is working ! LOL

1 Like

Looks like you figured this out I think. Yea, that is the last step - just press continue to finish.

1 Like

I haven’t seen that one before @hausofcode. Did you try to closing and opening a new terminal? That may work. I think just closing the terminal won’t “close” it - you have to use the little trash can icon.

You could try opening a different project. That will shut down the running VM in the image. Then go back to this project to open it back up. That may fix it.

Were you able to solve the problem?

I am taking the Learn Git by Building an SQL Reference Object course. Each time I entered git log command, everything stop progressing further. I experienced this severally when I was running the course on my system. I changed to the browser version because I felt it wasn’t going to happen here but the experience is the same. I have tried opening new terminals and still get same result.

Did you try using the reset button @oromesuo1?

I have tried severally without resolution

Hey @jorge.chavarriaga, did you end up having to delete your container and start over to fix the problem you mentioned above?

I have completed the Build a Celestial Bodies Database challenge. I got to the congratulations page. I saved my challenge in universe.sql file and uploaded it in a git repo.
After the congrats part, I opened freecodecamp site on another tab, copy pasted the url. But if I click on the submit button, it says ‘you must complete the project first’, which I did.
So I again opened my container, got the congrats prompt. Then I reloaded the page, and it redirected me to the challenge page. I submitted the url, still it says you must complete the challenge.
Please need suggestions to complete the stage.

There’s several troubleshooting steps at the top @tanjimanim007. Did you try those? If you signed out of freeCodeCamp at all, that third one is likely the problem.

Hi, quick question

I’m currently finishing my celestial bodies database and I keep checking everytime i finish a table if I meet the requisites before I move on to the next table, so far so good but when i hit run it doesn’t check the requisite for having INT in at least two columns that are not the pkey or the fkey, but i have almos 6 that are not and still i don’t get the check. (screenshots below)

Looks like there’s a bug in that test @andrescerchia. It assumes your keys are all integers. It takes the number of integer columns minus number of keys and checks that it’s >= 2. Your keys aren’t integers, so it looks like it takes 7 (number of INT's) - 7 (number of keys) = 0. Which is not >= 2. If you want to pass, you could just add two more integers, or change the keys to integers. I will create an issue around this to get it fixed.

Just curious - did you pass the “Each primary key should automatically increment” test? I assumed users would use the SERIAL type for all the primary keys, which would make them integers.

Thank you for the answer, yes I’ve passed it. And I didn’t use INT on the keys, on purpose, because of the rule we discussed.

So to recap, to work around the bug, I should add two more columns with the INT data type?

So to recap, to work around the bug, I should add two more columns with the INT data type?

That should work.

Thanks a lot man. That helped me too.


Hi! I have a small problem with terminal.
When I try to paste anything to the terminal i get this error message.
Tried using Chrome, Firefox and Edge with same result. I just finished World Cup Database and it made made debugging queries script really annoying.

1 Like

That’s an el (l), not a one (1) @KeshavMaheshwari

I am currently on Learn Bash by building five programs challenge.
So, I am at the challenge where you have to run the file after you add the echo $QUESTION1.
It says on the challenge that,
“Run the file like you did before to see if it worked.”
I typed ./ The file ran but the didn’t pass the challenge. What should I do now? I refreshed and clicked the run button. Still no progress.
Edit: I tried typing bash and also sh
The file is running and showing “What’s your name?” on the terminal.
Still don’t know what’s the problem.

You could try the reset button and doing that step again @tanjimanim007.

If that doesn’t work, I feel like it might be a similar problem described in this thread. I’m in the process of restructuring some things in the tutorials to try and resolve this type of issue. It’s a very frustrating issue.

Let us know if either of those work.