Running the Relational Database Curriculum in your Browser

Hi @charss – it sounds like I was having the same issue you were having. Perhaps what I did will help you, if you haven’t tried it already.

Once I completed the Celestial Database project (got all the tests to pass, etc.), I clicked the blue “Continue” button as you did. Then, from within the same Chrome browser window in which I was viewing the Code Ally VM, I refreshed the page, and it took me back to the regular Free Code Camp site, only with a new check mark next to the “Step 1: Complete the Project” prompt, seen here:

From there, I was able to paste in the URL to the github repo in which I included my universe.sql file, and it said I completed the project.

Hi, I came across this issue where the CodeRoad doesn’t let me pass. I was stuck in creating roboto.font file when my browse suddenly refresh itself and now the CodeRoad seems not working on my end

hey guys , anybody know why won’t the name and num variables come out in the terminal ?, as you can see there is nothing wrong with the data in the table

Here’s what I would try @equillibrium - Click the reset button - after it’s done resetting, close the terminal by typing exit into it or using the trash can icon at the top right of it - open a new terminal and do the step again.

I think it’s cause there’s a space in the GET_SYMBOL @heil-ham. You can see the (<space>O) in your output. Try using $1 in your GET_NUM and GET_NAME queries instead of GET_SYMBOL - if that works, then the problem is probably that space.

works fine on mozilla too.

It worked, thanks for the help

I’d like to share a problem that I see with the Building a Student Database project part 2. Around 85%-86%, it asks us to select the first name, last name, major and gpa of students who’s major is data science or who has a gpa of 3.8 or greater. When I did it and got the result it asks, it didn’t accept it. When I got a hint, I realized that it was divided into three steps, first is getting all the data using * and not using WHERE, and second is using WHERE, and third step was selecting the correct columns. Which was not stated in the task. So even though I was getting the result it asked, it wasn’t accepted. There are so many more tasks like this, but I forgot where they were exactly. I had to get all the hints to see what it was asking for all those tasks. I’ve lost so much time trying to figure out where I made a mistake, even though I didn’t make any.

EDIT: There was another one right after this one:( Again I’ve spent so much time to figure out how to get the correct result, but it didn’t accept it. I figured what the issue was when I got all the hints. It was divided into steps:((((

So I was doing the boilerplate project but my inputs stopped being evaluated completely. Right or wrong input doesn’t matter. I get no message from the tutorial panel. I cannot progress further.

hi everyone! i need help with “Learn SQL by building a student database part 2”. I’m on the step six and here’s this issue
The task is to display “students” database (i did the previous step by copying my “students” database from previous challenge, it worked fine). I did as it said but CodeRoad didn’t approve it.
When i click “run” in says that “you should list the database”, and i try “\l” command too but it doesn’t work as well.
how can i fix it?

I finished the whole Relational Database Curriculum(beta) at last. It was a really fun and sometimes a bit frustrating because it’s beta, and it’s still in early stages.
But otherwise it’s a good course.
I just had one question though, the database projects which I have done, if someone wants to do it on their local editor or something, what would be the steps are? I added all the projects repo in my Github account. So it would be nice to add a little file if someone wishes to do it locally or wants to run the .sh files locally.

1 Like

I always have to start my commands from the beginning each time I come back to the VM to continue after reopening VS code. Is there no way I can save progress? I know it autosave but I’m referring to the terminal code that got me to the latest check point

I get this error when I try to paste on the terminal:
“Unable to read from the browser’s clipboard. Please make sure you have granted access for this website to read from the clipboard.”

Pls, I need help to fix this. I am sure access is granted to all sites by default in my settings and I am not blocking any site from accessing clipboard.


Try a right-click + copy/paste @Damola007. That should work.

I just had one question though, the database projects which I have done, if someone wants to do it on their local editor or something, what would be the steps are?

To run these locally, you can follow the docker setup guide. This will give you a container on your computer that is the same as the one you run on CodeAlly. Technically, you could do it without the container, but the container will have all the programs you need (postgresql, nano, git, etc.) and the file system will be the same. So, setup the container, then there’s a few commands that the tutorials run for you to start postgresql, and maybe set up some users. Opening the tutorial with CodeRoad will run those for you - or, you can try to run them yourself - here’s the commands that the salon project runs. You may need to dig into those a little.

1 Like

I get this error message while trying to start CodeRoad. I can I fix it please?
Command ‘CodeRoad: Start’ resulted in an error (command ‘coderoad.start’ not found)

1 Like

I am stuck on this and no matter how many times I refresh I cannot connect.

I’m having the same issue.
Even deleting the project and starting it again didn’t seemed to work.
¿Maybe some bug with codeally? Was working just fine yesterday.

Are you still having issues @fengkeven @Santiago-Motter? I was able to open up a course just now.

Were you able to work around that issue @Damola007? I haven’t seen that one before - seems like the CodeRoad extension didn’t get installed or something. Can you close that window and then open the extension manually? There’s instructions at the top for how to do that.