Running the Relational Database Curriculum in your Browser

I’m not sure if you’re understanding what I’m saying @oromesuo1. I didn’t mention anything about third party cookies in that message. If your script is still the same as the files you shared, then that shouldn’t be the issue. The problem is that when you run your script, with ./ or ./ H, the script doesn’t finish running. It is waiting for input - the test doesn’t give any input, so the tests just keep running because the script doesn’t finish. You need to make it so that if you run those commands, your script will finish running.

For now, if the tests hang like that, here’s what I would suggest - close CodeRoad, make sure your script will finish when entering commands like that, and open CodeRoad back up.

Still not working… The same error appears even after refreshing the page.

Unfortunately, I think you may have to start over @maby200. The dark theme isn’t being applied so I think something got messed up in your VM. There’s another issue with more detail here. There’s instructions how to start over here

I haven’t seen this come up since we thought we resolved this. Do you recall when you first started this project?

Ok I have actually updated the script and it is running and providing the required output when I run it with ./ or ./ H. I am surprised that CodeRoad Run button just keeps spinning continuously
Here is a screen shot of the project with CodeRoad closed.

The screen shot above shows that the script runs and finishes in both cases.
The files are still available on my github repo:

K, I’ll give it another try

1 Like

Yes, when I run the script doesn’t finish…
Screen Shot 2022-04-21 at 8.05.51 AM

It’s just waiting for input there. Comment out or delete the read USER_INPUT on line 83. Then close CodeRoad and open it again.

Finally that solved it. That line on my code and the call to MAIN was the problem.
Thank you!
Thank you!!
Thank you!!!

1 Like

I’ve often solved this issue by loading another container.

To do so, just open another course from this curriculum, and then RE-OPEN the one you just completed. Click the OK button. Then go to the page where you can submit the github link of your project and now, you should have your check mark near the title.

Sorry, was away from PC for few days, is it solved now? If not here is the trick, use them in quotes like → echo ‘#!/bin/bash’ >

1 Like


I’ve tried the recommendations at the top by resetting my VM and starting another one, even pushed my repo to GitHub, but it still doesn’t appear as complete on the FCC main page

Now I’m getting this problem on the VM

Do I need to install an extension? I’ve tried resetting it multiple times but nothing changed

I’m stuck on this part of Learn SQL by Building a Student Database: Part 2. I’ve ran the script a dozen times but the course doesn’t progress. I even tried changing directory and back to the projects one, but still nothing. Any ideas?

Have you tried the reset button @nickpartalis? Sometimes something gets a little goofy, that may work. Are the tests running automatically? If so, what is the error message you are getting?

Were you able to get your progress saved with that world cup project @andrescerchia?

The theme is missing in your second picture there, I’m not sure why that happens - but every time I’ve seen it, the person has had to start over to get it working again - unfortunately. Something gets messed up in the VM I think. There’s another button that will be coming soon that should resolve this problem.

Thx for the reply !

The progress is saved but only for me on the world cup project, not on the FCC page

So, to be clear @andrescerchia - you finished the world cup project and clicked the continue button shown in this image from the troubleshooting steps, and you don’t see the checkmark highlighted here:

And you tried all the troubleshooting steps. Seems like that should have worked - I would try them one more time. If it still doesn’t work, I would delete the container and re-complete the project. You have all the files to finish it again without having to write more code. Beyond that, I’m not sure what else to do. Let me know if any of that works.

There might be some problem in Edge browser. I can not access the projects directly from Freecodecamp site on Edge. I have to go through Codeally browser or change to Mozilla to work.

I deleted the vm and copied pasted everything again and it worked! Thank you for the support

1 Like

Make sure you have third-party cookies enabled @tanjimanim007 - that could be the issue with edge you were having. I would recommend using chrome, it’s probably the least likely to have any issues - I have been able to run these without issue on most browsers though.

I remember it was on the first days in february.