Sass: Use @for to Create a Sass Loop - most of the Sass examples doesn't work

Most of the Sass examples doesn’t work (same is with this one)… Even tho the text windows shows the correct result

Your loop should only create 5 classes. Your code creates 6. From now own please share your code (formatted) rather than screenshots.

I have the same code with the correct loop and it still doesn’t work…

Attach the link please

It doesn’t work for me either.

The variable challenge doesn’t work for me either.

Hi there, it works, just try to make your code equals to the example, try 10px * $j; with spaces between , it takes a while to figure but it should work, it worked for me when I put spaces as in the provided example. :slight_smile:

1 Like

That’s actually what I had originally. I even tried taking out the extra row above and below the for loop like you have in your example, and it’s still failing.

image

This is all I’ve been able to complete of the SASS challenges.

I’m still learning it, so that’s good, but I hope this doesn’t stop me from getting the cert…

Can confirm I’m experiencing the same issues. Interestingly, for the portions that did not work, I was sometimes able to get them to pass by refreshing and ctrl-entering a bunch of times until it eventually worked.

I wonder if the problem may be a race condition: in my browser, the HTML content first renders unstyled, and it visibly takes a few ms for the SASS styles to be applied. Perhaps the tests are finishing before it does this?

1 Like