Sass @while issue

Sass @while issue
0.0 0

#1

Tell us what’s happening:
I can not pass the tests despite the code seems to work in the right panel.
Any hints?

Your code so far


<style type='text/sass'>
  
  $x:1;
  @while $x<11 {
    .text-#{$x}{font-size:5px*$x;}
    $x: $x+1;
  }
  
  
</style>

<p class="text-1">Hello</p>
<p class="text-2">Hello</p>
<p class="text-3">Hello</p>
<p class="text-4">Hello</p>
<p class="text-5">Hello</p>
<p class="text-6">Hello</p>
<p class="text-7">Hello</p>
<p class="text-8">Hello</p>
<p class="text-9">Hello</p>
<p class="text-10">Hello</p>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36.

Link to the challenge:
https://learn.freecodecamp.org/front-end-libraries/sass/apply-a-style-until-a-condition-is-met-with-while/


#2

your code worked for me, so maybe try resetting the code back, then pasting your code in and re-running.


#3

No still nothing :frowning:


#4

This is interesting. I went back and re-ran the exact same code with zero change and this time it fails.
I’m guessing there is a freecodingcamp bug here, but let me see if I can find a way to get past it anyway. I’ll get back to you if I find anything but in the meantime, you should probably open a bug report.


#5

Tried again but first I clicked the button “Reset all code” and accepted the “are you sure” statement.
Once everything was cleared by freecodecamp I pasted your code and it worked again!
So , please try to reset (don’t clean it up manually, use the button). If you’re still having problems, I do encourage you to open a bug, and maybe move on to something else in the meantime. (explain in the bug report that other people who tried were successful etc.)


#6

Thanks for your time. Still nothing after reseting! I will make an issue at github about this.