Setting a position property to absolute

Tell us what’s happening:
Describe your issue in detail here.
i have set a position property to absolute but its returning an error.

  **Your code so far**
  #black-character {

position:absolute;
top: 30%;
left: 59%

/* file: index.html */
<!DOCTYPE html>
<html>
<head>
  <meta charset="utf-8">
  <title>Picasso Painting</title>
  <link rel="stylesheet" href="./styles.css" />
  <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.8.2/css/all.css">
</head>
<body>
  <div id="back-wall"></div>
      <div class="characters">
        <div id="offwhite-character">
          <div id="white-hat"></div>
          <div id="black-mask">
            <div class="eyes left"></div>
            <div class="eyes right"></div>
          </div>
          <div id="gray-instrument">
            <div class="black-dot"></div>
            <div class="black-dot"></div>
            <div class="black-dot"></div>
            <div class="black-dot"></div>
            <div class="black-dot"></div>
          </div>
          <div id="tan-table"></div>
        </div>
        <div id="black-character">
          <div id="black-hat"></div>
          <div id="gray-mask">
            <div class="eyes left"></div>
            <div class="eyes right"></div>
          </div>
          <div id="white-paper">
            <i class="fas fa-music"></i>
            <i class="fas fa-music"></i>
            <i class="fas fa-music"></i>
            <i class="fas fa-music"></i>
          </div>
        </div>
      </div>
</body>
</html>
/* file: styles.css */
body {
background-color: rgb(184, 132, 46);
}

#back-wall {
background-color: #8B4513;
width: 100%;
height: 60%;
position: absolute;
top: 0;
left: 0;
z-index: -1;
}

#offwhite-character {
width: 300px;
height: 550px;
background-color: GhostWhite;
position: absolute;
top: 20%;
left: 17.5%;
}

#white-hat {
width: 0;
height: 0;
border-style: solid;
border-width: 0 120px 140px 180px;
border-top-color: transparent;
border-right-color: transparent;
border-bottom-color: GhostWhite;
border-left-color: transparent;
position: absolute;
top: -140px;
left: 0;
}

#black-mask {
width: 100%;
height: 50px;
background-color: rgb(45, 31, 19);
position: absolute;
top: 0;
left: 0;
z-index: 1;
}

#gray-instrument {
width: 15%;
height: 40%;
background-color: rgb(167, 162, 117);
position: absolute;
top: 50px;
left: 125px;
z-index: 1;
}

.black-dot {
width: 10px;
height: 10px;
background-color: rgb(45, 31, 19);
border-radius: 50%;
display: block;
margin: auto;
margin-top: 65%;
}

#tan-table {
width: 450px;
height: 140px;
background-color: #D2691E;
position: absolute;
top: 275px;
left: 15px;
z-index: 1;
}

#black-character {
width: 300px;
height: 500px;
background-color: rgb(45, 31, 19);
#black-character {
position:absolute;
top: 30%;
left: 59%

}
}
  **Your browser information:**

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/102.0.5005.115 Safari/537.36 OPR/88.0.4412.53

Challenge: Step 39

Link to the challenge:

I have worked it out. the solution is removal of the repetition of
#Black-character {
}
after i removed the repeated selector, it worked pap!
also the semi-colon missing on the property left
left: 59%
to
left: 59%;