Task 11: All 16 tests are not passing Metric Imperial Converter

**Hello guys. I’m having problem passing the 11th test:

All 16 unit tests are complete and passing.

Before i started working on the unit tests. All previous task where passing. But after i solved it , they all fail except the first two task. Please, What seems to be the problem? I believe it’s from my code but i just don’t want to jump into conclusions.

**

My Repl.it Code so far: https://repl.it/@Micode111/boilerplate-project-metricimpconverter#tests/2_functional-tests.js

solution: https://boilerplate-project-metricimpconverter.micode111.repl.co

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.192 Safari/537.36.

Challenge: Metric-Imperial Converter

Link to the challenge:

Hello there,

This might not be your issue, but it might help to try this:

Some Campers have benefit from increasing the timeout in server.js:

setTimeout(function () {
      try {
        runner.run();
      } catch(e) {
        let error = e;
          console.log('Tests are not valid:');
          console.log(error);
      }
    }, 1500); // Increase this, try 5000

Otherwise, and this is not ideal, some Campers have found that starting the app, and immediately submitting it passes the tests.

Hope this helps

It’s still not working. Still trying to think this through.