Tensorflow error

Hi, please help! This code is not working and I am not too sure what’s going on.

I am hoping for the graph to look like this:

code:
import tensorflow as tf
import matplotlib as mpl
import matplotlib.pyplot as plt
import numpy as np
import os
import pandas as pd

Output:
/Users/gloriali/anaconda3/bin/python /Users/gloriali/PycharmProjects/pythonProject/venv/LSTM.py
2023-07-29 15:55:54.185966: I tensorflow/core/platform/cpu_feature_guard.cc:182] This TensorFlow binary is optimized to use available CPU instructions in performance-critical operations.
To enable the following instructions: SSE4.1 SSE4.2, in other operations, rebuild TensorFlow with the appropriate compiler flags.
Traceback (most recent call last):
File “/Users/gloriali/PycharmProjects/pythonProject/venv/LSTM.py”, line 1, in
import tensorflow as tf
File “/Users/gloriali/anaconda3/lib/python3.10/site-packages/tensorflow/init.py”, line 441, in
_ll.load_library(_plugin_dir)
File “/Users/gloriali/anaconda3/lib/python3.10/site-packages/tensorflow/python/framework/load_library.py”, line 151, in load_library
py_tf.TF_LoadLibrary(lib)
tensorflow.python.framework.errors_impl.NotFoundError: dlopen(/Users/gloriali/anaconda3/lib/python3.10/site-packages/tensorflow-plugins/libmetal_plugin.dylib, 0x0006): Symbol not found: (OBJC_CLASS$_MPSGraphGRUDescriptor)
Referenced from: ‘/Users/gloriali/anaconda3/lib/python3.10/site-packages/tensorflow-plugins/libmetal_plugin.dylib’
Expected in: ‘/System/Library/Frameworks/MetalPerformanceShadersGraph.framework/Versions/A/MetalPerformanceShadersGraph’

Process finished with exit code 1

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.