Test failed, but i do right

Your .follow-btn should have a display property set to flex. - but I do it right.

Your code so far

body {
  font-family: Arial, sans-serif;
header {
  display: flex;
header .profile-thumbnail {
  width: 50px;
  height: 50px;
  border-radius: 4px;
header .profile-name {
  display: flex;
  margin-left: 10px;
header .follow-btn {
  display: flex;
  margin: 0 0 0 auto;
header .follow-btn button {
  border: 0;
  border-radius: 3px;
  padding: 5px;
header h3, header h4 {
  display: flex;
  margin: 0;
#inner p {
  margin-bottom: 10px;
  font-size: 20px;
#inner hr {
  margin: 20px 0;
  border-style: solid;
  opacity: 0.1;
footer {
  display: flex;
footer .stats {
  display: flex;
  font-size: 15px;
footer .stats strong {
  font-size: 18px;
footer .stats .likes {
  margin-left: 10px;
footer .cta {
  margin-left: auto;
footer .cta button {
  border: 0;
  background: transparent;
<img src="https://freecodecamp.s3.amazonaws.com/quincy-twitter-photo.jpg" alt="Quincy Larson's profile picture" class="profile-thumbnail">
<div class="profile-name">
  <h3>Quincy Larson</h3>
<div class="follow-btn">
<div id="inner">
<p>I meet so many people who are in search of that one trick that will help them work smart. Even if you work smart, you still have to work hard.</p>
<span class="date">1:32 PM - 12 Jan 2018</span>
<div class="stats">
  <div class="Retweets">
    <strong>107</strong> Retweets
  <div class="likes">
    <strong>431</strong> Likes
<div class="cta">
  <button class="share-btn">Share</button>
  <button class="retweet-btn">Retweet</button>
  <button class="like-btn">Like</button>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 Edge/18.18362.

Challenge: Add Flex Superpowers to the Tweet Embed

Link to the challenge:

Your code is passing for me.

It’s likely a bug with an ad block extension. Try disabling any such extensions you may have installed and run the test again.

Edit: Woops I also just saw you are running Edge. Chrome and Firefox are really the only browsers that is fully supported for the curriculum. I’d suggest using one of them.

in Chrome fail too… I use Edge and Chrome)

Do you see the follow button in the top right of the preview output?

The page should look like this.

If you do not see the follow button then something is blocking it, most likely some form of ad blocking.

  1. Make sure you disable any ad block browser extension installed. Run Chrome in Incognito mode to test without extensions.

  2. If you have any software running that blocks ads, temporarily disable it.

  3. You might be using a DNS with ad blocking if so temporarily switch to a different one (you would most likely know what this means if you do, if not just ignore this).