Use @each to Map Over Items in a List: not passing tests even though answer is (rpobably) correct

Use @each to Map Over Items in a List: not passing tests even though answer is (rpobably) correct
0.0 0

#1

For some reason, I can’t pass this challenge, but I’m pretty sure I did it correctly. I ran a search on the forum here and saw a number of people had the same issue so I imagine it’s some kind of bug. Did anyone found a workaround?

Your code so far


<style type='text/sass'>
  @each $color in blue, black, red {
    .#{$color}-bg {background-color: $color;}
    }
  
  div {
    height: 200px;
    width: 200px;
  }
</style>

<div class="blue-bg"></div>
<div class="black-bg"></div>
<div class="red-bg"></div>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.87 Safari/537.36.

Link to the challenge:
https://learn.freecodecamp.org/front-end-libraries/sass/use-each-to-map-over-items-in-a-list


#2

There’s an issue with sass challenges. Many have the same problems.


#3

Yeah, I’ve hit run tests like a million times and it’s still not passing. I’ve adjusted the spacing to every possible combination and still nothing.


#4

Nevermind, tried 5-6 times in a different browser and it worked :slight_smile:


#5

I passed through the same problem! We have to be patient until someone fix that tests.
After a while I found https://www.sassmeister.com/ to see the result of sass code. There you can paste the sass code and see into which css code is translated.


#6

Yesm it also happened to me once, and then instead of continuing to the next challenge I clicked the X to go back to the code, and then try to run the test again, and didn’t pass. Crazy!