Why is this icon not showing up?

Does anyone know why this icon isn’t showing up? Here’s the html code:

   <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css">	

<div class="icon"> <i class="fas fa-fire"></i></div>

All I’m getting is this (a fire should show up, not a square):

The class attribute should be equal to fa fa-fire instead of fas fa-fire.

1 Like

You are using the old CDN to link to font awesome, The CDN has changed for Font Awaeome v.510.2, so now you need to use:

<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.0.7/css/all.css">

1 Like

The fa prefix has been deprecated in version 5. The new default is the fas solid style and the fab style for brands

See here:


1 Like

Replace the link from https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css to the new one which is https://use.fontawesome.com/releases/v5.0.7/css/all.css. This should help.

At least it works for me:

1 Like

Hi @Tobiasman

I’ve didn’t noticed you have already solved it :clap: :slight_smile:

@timagixe, No problem :slight_smile:

Thank you for your our help, it solved my problem! :slight_smile: Where can I find the CDN link? (for future versions)


For example, here: CDNJS

1 Like