You should have one self-closing link element

It keeps telling me the link element is not closed but it already has a /
I don’t understand. What should I do?

This is the indication:
Within the head, nest a meta element with a charset of UTF-8, a title element with a title of City Skyline, and a link element that links your styles.css file.

Link to the challenge


    <meta charset="UTF-8" />
    <title>City Skyline</title>
    <link rel="stylesheet" href="styles.css" />  


Sorry, your code does not pass. Keep trying.


You should have one self-closing link element.

Can you include a link to the challenge please? Otherwise, it’s difficult to know what might be going wrong.

I added it in the post. Thanks in advance for your help.

There’s nothing wrong with this code, but can you paste your complete code for the HTML file please?

Here it is:
I don’t even have that much done since is Step 4… :frowning:

<!DOCTYPE html>
<html lang="en">
    <meta charset="UTF-8"/>
    <title>City Skyline</title>
    <link href="styles.css" rel="stylesheet" />

There’s nothing wrong with your code.
Do you have any browser extensions enabled?
These can interfere with the tests, so disable all browser extensions.
Also, try resetting the lesson and reinputting the code, or reload the page with CTRL+F5 and try resubmitting.
Failing all else, try using a different browser.

1 Like

I’m gonna try all of this. Be back to report, thank a lot!

OMG it worked!!! I did everything you said, reload the page, resettled the lesson and nothing worked until I changed a different browser, there I realized It was probably chrome and the extensions I had there so I unenabled all of them and it worked.

Thank you so much! I never would’ve been able to solved it without your help, really appreciate the help. Thanks :pray:

No worries - the problem with browser extensions is that they can inject additional HTML/CSS into the page, which is absolutely fine except that it can make FCC’s tests fail for HTML/CSS-based challenges.

I didn’t know this. In the future I’ll be more careful with the extensions I install!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.