Another Mystery About Bootstrap in CodePen

Another Mystery About Bootstrap in CodePen
0

#1

I used this code in CodePen and it did not work.

Bear in mind that I put the settings on Bootstrap in this Pen. I used this code but the class “well” would not work. When I used the class “jumbotron” it worked fine.
but
When I used the code in the FreeCodeCamp sandbox/cellphone, it worked perfect, but on codepen it didn’t work.

Isn’t there supposed to be a grey area with rounded corners for the class “well” also in codepen?

Anyway, here is the code I used for the class “well”. Remember, I used the exact same code with the class “jumbotron” and it worked perfectly.

<div class="container"><div class="well">This is a well. You can put all sorts of words into a well.</div></div>

Thanks in advance!
Elmo


#2

There is no well in Bootstrap 4.


#4

P1xt,

Thanks so much for that my friend! It was a big help!

You da man!!!

Elmo


#5

Just to add, the bootstrap on codepen is the twitter bootstrap, their bootstrap syntax is quite different from the other bootstrap. Sometimes even the navbar does not work well. So just add bootstrap 3 cdn to your codepen


#6

@ugumerie I’m not sure if your implying there are literally two separate Bootstrap frameworks, but to clear the confusion just in case: CodePen uses the same Bootstrap that FCC or any other online editor might use, the only difference is the version. CodePen is using 4.0.0-alpha while most others are still on 3.3.7-stable.


#7

Yeah you can check…one is being maintained by twitter dont know who maintains the other


#9

Thanks for that information…my bad