AWS How to enable cost explorer?

Hello friends, I am following the video : AWS Certified Cloud Practitioner Certification Course (CLF-C01) - Pass the Exam! when the time at : 1:03:00 he clicked the budget and I tried to follow him to click the button. Then this appear:


When I click
image

then when I click the link :

then this appear:

So I tried so many times but still can’t figure it out, do you know how to solve this? thank you so much! :slightly_smiling_face:

I’m not very familiar with AWS yet but this may help

I tried it , same as what I wrote it .

The cost explorer is enabled for an entire account. The final screenshot implies that you are trying to enable it as a created user on that account (ie a non-management user, one not in control of billing), which you can’t do. It looks very much to be a permissions issue.

yes right , I think so . I log out and log in again use the root user then this:

so seems I need to wait for 24 hours?

That’s what it says in the docs, yes.

Edit: note that you need to be very careful with this: if you access it via the CLI it will charge you $0.01 for every page of paginated data & once enabled, you cannot turn it off. It is quite squarely aimed at enterprise users for whom the cost is largely irrelevant.

1 Like

ok I will pay attention about that , thank you for your help

1 Like

You must still enable it by performing the following procedure. Sign in to the AWS Management Console and open the AWS Cost Management console at https://console.aws.amazon.com/cost-management/home . On the navigation pane, choose Cost Explorer. On the Welcome to Cost Explorer page, choose Launch Cost Explorer.

I click the link then this :