Back End Development and APIs Projects - Timestamp Microservice

Tell us what’s happening:
Hi, all my tests are passing yet I do not get a confirmation that I have passed the challenge. When I run the app, it was working and no errors came up.

Can somebody pls help me out? Am I debugging it wrongly missing the errors or is my code wrong?

Your code so far
This is the link to the my source code: GitHub - mabelllll/fcc-project-timestamp

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/104.0.0.0 Safari/537.36

Challenge: Back End Development and APIs Projects - Timestamp Microservice

Link to the challenge:

Hi

Have you hosted your code somewhere (e.g. Replit, Glitch, CodeSandbox etc.) ?

You can run and submit the challenges locally, but not the projects.
They need to be hosted somewhere public.

I’ve been hosting it locally even for the previous lessons by submitting
http://localhost: with the port number shown at the terminal and it all works.

I just tried it again yet I don’t get any pop up to proceed to the next challenge.

This time the port number is 49363. Tests completed but I don’t have a pop up stating I completed the challenge.


Yes, you can submit the challenges using localhost.

But you can’t submit the projects that way.
That’s what the “Remember to submit a publicly visible app URL” message is telling you.

See this forum post from FCC staff for confirmation.

Ohhh. Okay, thank you @KittyMac. I tried it on replit and it works. Thank you so much!