Bug? Improve Accessibility of Audio Content with the audio Element

Bug? Improve Accessibility of Audio Content with the audio Element
0.0 0

#1

Tell us what’s happening:
It appears that I may have found another bug…
The compiler/parser says I don’t have a closing tag when I do.
I’ve tried different spacings, re-writing on different lines, double-checking to make sure I wrote without spelling or syntax errors.

Your code so far


<body>
  <header>
    <h1>Real Coding Ninjas</h1>
  </header>
  <main>
    <p>A sound clip of Zersiax's screen reader in action.</p>
    <audio id="Zersiax" controls>
      <source src="https://s3.amazonaws.com/freecodecamp/screen-reader.mp3" type ="audio/mpeg"/> 
    </audio>
  </main>
</body>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0.

Link to the challenge:
https://learn.freecodecamp.org/responsive-web-design/applied-accessibility/improve-accessibility-of-audio-content-with-the-audio-element


#2

Nevermind. It looks like the parser needs to have exact answers. It looks like my “id” was what confused the editor.


#3

I need help, because I have the following error (Make sure your audio element has a closing tag.) and I do not know how to overcome this problem being a bug …

<body>
  <header>
    <h1>Real Coding Ninjas</h1>
  </header>
  <main>
    <p>A sound clip of Zersiax's screen reader in action.</p>
    <audio id="meowClip" controls>
      <source src="https://s3.amazonaws.com/freecodecamp/screen-reader.mp3" type="audio/mpeg" />
    </audio>
  </main>
</body>

#4

Hi @Melquize,

You need to remove the id from the audio element to pass the challenge.

Hope this helps :slight_smile:

PS: You will usually get a better response if you create a new topic rather than reply to an old one.


#5

Thanks @oliverdudman