Building a Café Menu -- Step 22

Hi guys!

Anybody who could help me out!

So far I feel great and positive and full of motivation since I managed completing Cat Photo App and now “Cafe Menu up to Step 22” – “SO FAR! ! !”

Telling about this step – exactly: Did it happen to you that you got no interface at all? No introduction about the task, any “Reset” or “Help” or “Submit-Button”?

How to cope with that now?

I tried from the tablet (i Pad, different browsers, Firefox, Safari), Windows Desktop PC, MacBook (different browsers)… in any case it is the same problem.

Any relations, experiences, support?

Tell me please!

Thanks a lot!

Heyy.
You are making some great moves. Post your code here, and from there we will figure out where exactly the problem is.

<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />
    <title>Cafe Menu</title>
    <link href="styles.css" rel="stylesheet"/>
  </head>
  <body>
    <div id="menu">
      <main>
        <h1>CAMPER CAFE</h1>
        <p>Est. 2020</p>
        <section>
          <h2>Coffee</h2>
        </section>
      </main>
    </div>
  </body>
</html>

On the top you can see HTML of the "Café Menu" up to "Chapter 21" & on the bottom CSS with three required selectors.

body {
  background-color: burlywood;
}

h1, h2, p {
  text-align: center;
}

#menu {
  width: 300px;
}


BUT I want you to keep attention -- AS MENTIONED: My problem is not the code. Problem is that by "Chapter 22" any kind of interface disappeared to me.  There is no UI with buttons such as "Reset", "Help" or "Submit" and not least the task interface.

When you reset the lesson, do they re appear?

The crucial point is that I can’t reset anything as I could before or in example by the “Cat Photo App” before.

So as you mentioned: The “UI” with “Reset”, Submit “Task introduction” and so on. This is what disappeared in my screen view.

I just can do reset by reloading the page (turning arrow or “F5”) in Windows or Command /Apple button and letter “R” in Macintosh.

But as mentioned: This also does not change or “improve” anything at all.

This is my actual view (not sure whether you can open it or not): https://www.freecodecamp.org/learn/2022/responsive-web-design/learn-basic-css-by-building-a-cafe-menu/step-22

It perfectly displays all the buttons on my end. The browser you are using, is it up to date?

It’s cleared up, folks.

Chrome seems to have fooled me.

I’ve been working with Chrome for two to three weeks now (as long as I’ve been working on the Cat Photo app) and have always paid attention to the updates.

The further steps in the “Café Menu” also worked excellently. Well, at “Step 22” of all places, “the belt broke” and Chrome screwed me over (despite updates) by no longer showing me anything.

Now I’ve tried “Edge” again after a long time and it works great, as you say.

Because the truth is, I’ve been told many times that “Chrome” is the best, most stable browser for coding and comes with the most and most up-to-date plug-ins.

But I was taught otherwise.

Thank you too! ! !

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.