Button and hover colors does not work on my github live link

I have changed the button colors on my code and it does not work in my GitHub live project link but works locally. I already pushed my changes to GitHub . So Github has my updated code.
Here’s my live project link :Portfolio --v2
And here’s my project repo : Circle-Web-Development/Module-1-end-Project at main · naima-shk/Circle-Web-Development · GitHub
I’m attaching image of the locally run project for reference:


If you open your browser’s console, you will see you are trying to reference files in your repo incorrectly (resulting in 404 errors).

Try changing your stylesheet references from href="./css/bootstrap.min.css" to href="css/bootstrap.min.css"

@RandellDawson Thank you for the reply but it’s still there. I’m trying hard but no luck!

What’s still there?

Can you push your changes up to GitHub?

When I just looked at GitHub, there were changes 11 minutes ago, but you only seem to have changed one of the css reference file paths. There should have been three changes.

@RandellDawson Yes, I pushed my changes to Github but the color of the button and hover color do not appear yet…

@RandellDawson After applying changes to all of the 3 file paths links my UI has destroyed. The path changing solution does not work for me. :frowning:

When you used links like href="css/style.css", what errors (if any) showed in the console? I would need to see them, to help you further.

@RandellDawson It does not show any error on both github live page or locally neither it fixed my problem…

@naimiii Did some research and discovered if you are using a Jekyll theme, then any filename that starts with an underscore (_) will not be reachable. Try renaming the two files in the partials folder and change the two import paths in style.css to see if that works.

UPDATE: If you do not want to change your filenames, you can also create a file named .nojekyll and place it in your root folder and it will accomplish the same. I tried both ways and they worked on my own GitHub pages site.

1 Like

@RandellDawson Thank you for the efforts ,now it’s working fine. Have a Nice day.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.