Buttons: FCC vs Code Pen [Solved]

Buttons: FCC vs Code Pen [Solved]
0

#1

Back at work on FCC after a month off for house guests. Now I am trying to make the buttons I need for navigation in my portfolio page. For now, I am not using JavaScript… that will come later.

I have been reviewing all the stuff about buttons in the FCC “Cat App”. I even played with then to add some and change them in various ways. They work fine there. But when I use the same code for my portfolio project in Code Pen, they don’t work. Classes such as block, primary, etc. don’t have any effect.

When I first looked at my code today, I found a lot of extra stuff I didn’t need, which I first commented out to make sure it was not essential, then deleted. Maybe I actually deleted something I needed? Or, maybe I added something I don’t need.

All I am concerned about now is the buttons. I would like them to be responsive (as they should be) and of different colors. As far as linking them to the anchor text… that will come later. I also tried to create a button for a FaceBook link at the bottom of the page and it doesn’t show up at all.

Here is a link to my project as it stands now. It is a fork of my original so I can continue to work on other parts.

Thanks in advance for looking this over for me and sending suggestions!


#2

You will have to add Bootstrap to your codepen via the settings. In codepen all your links should be added in the settings and not in your html.


#3

Hi… I finally had a chance to check your reply. Yep, I forgot to add Bootstrap.Now it works! Thanks so much!