Can't install any package in atom

Can't install any package in atom
0

#1

I cant install any package in my atom editor. It displays following error message:
"Fetching featured packages failed.Hide output… write EPROTO 101057795:error:140943F2:SSL routines:ssl3_read_bytes:sslv3 alert unexpected message:openssl\ssl\s3_pkt.c:1493:SSL alert number 10 101057795:error:1409E0E5:SSL routines:ssl3_write_bytes:ssl handshake failure:openssl\ssl\s3_pkt.c:659:


#2

Here’s a guess, so take it or leave it. Try running your editor in admin mode from command line. I am still having problems on my new computer with my account not having root control. I can’t search packages from the editor without running in sudo, and certain plugins won’t work either.


#3

Could you plz tell me in more detail as " how to run editor in admin mode". Sorry I am new for this.


#4

If you are using Linux you can use the ‘sudo’ command before the name of the application you want to run.

I am currently using SUblime Text 3 which changed their program name to subl

So I type this in the terminal. You can open your terminal with ctrl + alt + T

sudo subl

#5

I am using window. How to do in window?


#6

right click on the application icon and open as administrator


#7

I did this already but still it is same. Still cant install any package.


#8

Check this thread: https://github.com/atom/settings-view/issues/924


#9

Nothing much here for my issue.


#10

It looks like exactly the same issue under the hood: have you tried uninstalling Atom & installing the 32-bit version, as the last answer suggests? Because if that works, then it’s an issue with the version of Node (odd number, so experimental with no long-term support) used in the Electron framework that powers Atom (ie problem with Electron using an unstable version of Node which causes OpenSSL to error on certain CPU architectures).

You could also try installing the Atom Beta and seeing if that works, I think it uses a different version of Electron. You can do that alongside your current version of Atom, there’s no issue having both on the same computer.

Edit:

  • Other releases here. 32-bit version is the link that’s just atom-windows.zip rather than atom-windows-x64.zip.
  • Atom beta is here. Note that if you use the command line to interact with it (install packages, open it etc), you use atom-beta some-option rather than atom some-option

#11

Thank you so much. I tried both option. but installing 32-bit Atom setup is working well. Thank you so much again.