Can't pass the test with my git repo

Tell us what’s happening:

I’ve cloned the git repo to my local computer , and then added author key to package.json as asked. Then I pushed it to a new git repo on my own GitHub.

Problem is:
When I enter the link of my repo to check, it doesn’t pass the test.

I tried with repl.it as well, still won’t work.

Your code so far

My repo: GitHub - abroroo/npm-fcc at gomix
My repl: https://replit.com/@abror/boilerplate-npm#package.json

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/97.0.4692.71 Safari/537.36

Challenge: How to Use package.json, the Core of Any Node.js Project or npm Package

Link to the challenge:

Hi @abroroo

The challenge instruction says

When you are done, make sure a working demo of your project is hosted somewhere public.

When you submit the URL to the GitHub repository, it won’t work because the repository is having the source code. The test requires a running server. If you are hosting the project on repl.it, then make sure the project is running and you are submitting the correct URL.
image

I suggest you clone the FCC repl.it starter project and proceed from there. I hope that helps.

HI @abroroo !

You can run these challenges locally but you have to submit the localhost link.
Not your github repo.

Here is an article on how to do that.

1 Like

Thanks a lot!! It worked.

My issue was that I had not published my GitHub repo online. It now works with both the GitHub repo and localhost!

Thank you for the help!