Challenge QA chai not working

Tell us what’s happening:
The code isn’t working for this challenge even when I use the solution from the hints.

Your code so far

/* I cannot get this to work think something is wrong on the site because this is the answer from the hint */
      test('send {surname: "da Verrazzano"}', function(done) {
        .send({ surname: 'da Verrazzano' })
        /** place your tests inside the callback **/
        .end(function(err, res) {
        assert.equal(res.status, 200, 'response status should be 200');
        assert.equal(res.type, 'application/json', 'Response should be json');
        assert.equal(, 'Giovanni');
        assert.equal(res.body.surname, 'da Verrazzano');


Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.88 Safari/537.36.

Challenge: undefined

Link to the challenge:

Hi Nick. This one worked okay for me. Are you getting any error messages? Could you please provide the link to your Glitch app?

The Glitch app reset itself at one point yesterday. I had to do the functional exercises over as I hadn’t saved the code. I can try again later today. I’m worried the Glitch app doesn’t persist history? Does it have an expiration period?


That’s weird. I haven’t had any issues with my Glitch apps not auto-saving my progress. I do try to export to GitHub at least once a day though just to be safe. Maybe check your Glitch profile for the recent apps you worked on, just to make sure you didn’t start working on a different one inadvertently?