Codepen. Css displaying as text above html. Help!

Codepen. Css displaying as text above html. Help!
0

#1

Does anyone know why the CSS in this product landing page is being displayed as text above the html? It seems to work properly when the file is copied/pasted from sublime text however as soon as it saves, weird things happen. I have used codepen a lot before with no issues. I successfully uploaded this exact file earlier today as well which worked. Anyone have any ideas on how to resolve this? Or is it a bug in the program?


#2
<style>
  @import url('https://fonts.googleapis.com/css?family=Gothic+A1');
</style>

I think the problem is here. This is in your CSS pane. It is already in a CSS pane so there is no need to wrap it in style tags. That is what you would do if you were putting this in an HTML file/pane. Somehow that is confusing codepen.


#3

Hey Kevin. Thanks for that. Yeah that was the first thing i tried. I also removed the css link in the header of the html with no luck either. I think codepen might just be having a meltdown haha


#4

It seems to work for me now.

I would recommend removing settings/behavior/auto-updating. It’s a pain in the ass and I’m never sure if what I’m seeing is the latest. I’d rather hit “run” and know for sure. I suspect this is throwing you off - you change the file but it doesn’t update. When I remove those tags, it works for me.

I hate all auto-updaters. They just annoy you by crashing as you type and then when you need them to run, you’re never sure if they have.


#5

Thanks so much. Its working now. That was driving me nuts! You just made my day :grinning: