Codepen not working

text cursor not showing up where I need to code how do I resolve this issue?

some people have already reported this
maybe look at their topics and see if something can work for you

https://codepen.io/Shobhit_k/pen/wvzjeWv
I have just forked this project and after that i am unable to use codepen.io. It only is showing the end output but i am unable to edit anything with it…
please someone help me on this.
Also if i want to run the test cases on my local environment then i just have written this code but all i am getting with this is a hamburger icon with no tests involved. so how can i actually test my code with the provided tests??

click on the hamburger icon, then select the project from the drop down menu, then use Run tests button - clicking on the result will give more infos

for codepen, there are already 4 topics open on it

this is the most recent one, just a few posts down in the Latest topics:

@ieahleen thank you so much for your kind help and yes there are lots of people facing the issue on codepen :cry::cry:.


I am unable to make a new pen or edit an existing one do I have to pay to use codepen.io

I think you can only have 1 project free but you can create as many pens as you want.

I mean to say unable to make a new pen or edit a existing pen

please look at recent topics before opening a new one, this is the sixth topic

I have removed all the extensions and adblocker but still, I’m facing the same problem. If anyone knows how to fix it pls help me.

Here is the link to one of my project: https://codepen.io/h_r_26/pen/abmYERv

I’m unable to view my code. Please help.

Hey @h_r_26!

Welcome to the forum!

Other users have posted about the same issue.

I can see your code on my end but we haven’t figured out the issue so far.

So this is a new issue with codepen that has come up in the last few hours.

there are a few thread on this. It seems an issue with codepen. My suggestion would be to use the export button and see if you can get your files with that - so you can have the code you have written so far, and then work on those somewhere else

You might want to reach out to codepen support if the issue still persists.

Sidenote: Your code looks really similar to the the FCC sample.

Remember that your projects only need to pass the user stories with your own style and code. These projects should not be copies of the sample.

1 Like

So what to do now? Is there any solution which you can think of mam?

If codepen is still having issues, then you can use the export button to get the code you have already written and use another source like codesandbox.

I am trying to do the projects of CSS i.e. Responsive Web Design projects.
So, whenever I try to open the project I am working on the HTML and CSS file don’t open (the files in which I write the program).
Here is a Screen Shot of what I am trying to tell :

What can I do?
I cannot proceed without getting this thing solved as, even if I create new pens they have the same issue.

Hi @alok.v.marathe!

Welcome to the forum!

Another user on the forum just posted about the same issue a few hours ago.

In that previous discussion, we tried the link on our ends and weren’t experiencing the same issue. So maybe a browser extension is messing with codepen right now?

Would you mind sharing your link to the codepen project so we can test it on our ends?

Yeah sure.
Here is the link:
https://codepen.io/Marathe07/pen/gOweZzG

And if possible, please help me with this project.
I am not getting the result of my project as I intend to.

I can see the code on my end

So maybe reach out to codepen support since multiple people are experiencing the same issue.

What was the intended result?

1 Like

I am trying to make a project just like this:
https://codepen.io/freeCodeCamp/full/RKRbwL

But the header which my project has is not correct.
The navigation-links are in vertical and I want them to be horizontal.