Comment Your JavaScript Code, nothing happening

Tell us what’s happening:
after I write the comment nothing happen, I’ve clicked on run the test and still nothing happened, what am I doing wrong?

can you please post your code sample

as it is my first time using the forum, it wont let me post links etc…
but it is the very first test on Basic JavaScript, it teaches how to write comments in Java, so my response was // testing code comment
and my second was /* testing code comment */

after that I was expecting to show me if it was right or wrong but nothing happened, clicked on Run the tests and still nothing happened.

You must submit both ways of comment.
On the first line create a // ... comment and on the second line create a /* ... */ comment.

On the left side you have the test that you need to pass, just scroll down to see them.

I have done that but the page doesn’t change… I wish I could post the link :frowning:

it won’t give any result because it is a comment. once it display the line you wrote if you have not properly comment it out. well comments are written just to make our code understandable to other readers and ourselves.
the syntax // is to write single line code
the syntax /* am
comment */
is for multiply line code.
Hope you understand better?

you can post the code on codepen and send the link here

I hope you can see the image now, so, the bottom of the screen says running tests after I’ve clicked on Run the tests, and then stays like that forever, don’t know how to move forward :frowning:

it is
/*testing a code
comment now */

:frowning: still nothing

His code works fine for me.

I’m sorry to say that but the browser is the problem. I tested now in Edge and the page didn’t react to “Run the Tests” button.
The code works fine in Chrome so maybe you can change the browser, I see that you have Chrome installed.


Chrome and Fireffox are the two browsers that, by and large, work reliably with FCC. Others have a pretty hit-or-miss performance.

@MissyJ can you switch your browser to chrome. I strongly recommend chrome

1 Like

Thank you ever so much :slight_smile: downloaded chrome and it worked woohooooo


thank you all for helping me :slight_smile: you guys rock


Glad you found a solution.

For reference, I thought I would try to help explain why the original test wouldn’t have worked.

Single line or in-line comment:

//too hungry to code, need to eat

Multi-line comment

/*too hungry to code, need to verify all of this is good after I've 
eaten a good tasty substantial meal*/