Create-react-app never ends and doesn't create any app

When I create a new react app with
npx create-react-app my-app
I only get node_modules and package.json and nothing else.
I also have to force it to stop, otherwise it never stops.

I searched for the solution and:

  • removed and installed newest node.js and npm
  • unistalled and installed back create-react-app
  • tried yarn create-react-app my-app
  • tried npm init react-app my-app
  • also npm install
  • npm cache clean --force & npm install -g npm@latest --force

None of this worked and I never could not get full react app.

I have been working with React for some time and never encountered this before.
I am Windows user.
What else I can do?

Well, I can only imagine 2 types of problems here:

  1. Permissions (very unlikely as npm would immediately throw an error)
  2. Network (most likely)

Did you try to ping package: npm ping create-react-app?

UPDATE: Actually, if install starts - ping would be ok :stuck_out_tongue: Try to create hotspot from phone and try again maybe.

nuclear option: delete all node_modules and npm files and folders manually then reinstall them

death star option: buy a new computer

Even I had the same issue and after lot of struggle found the fix . So, if you are unable create the app try reinstalling nodeJS in 32-bits and try it. This helped me fix this issue. Hope, it helps you too! Happy hacking :wink:

I am also facing the same issue. did you find any solution for this?