Error using Chrome React Developer Tools with create-react-app

Hello everyone, I’m getting an error using Chrome React Developer Tools with create-react-app.


It would help to see your full code to determine what is throwing the error message.

Hello nhcarriagn, I’m getting this error after downloading create-react-app, and I have not altered anything after downloading from the terminal and running npm start. I tried a couple of times but I still get an error message in Chrome dev tools.

How did you “download” it, did you run?

npx create-react-app my-app

Yes I used npx create-react-app my-app.

Can you tell me what/where common.js is? Click the file name in the console.

Does it work in a private window with all extensions disabled?

Also, If you have CRA installed globally try uninstalling it. Then run npx again.

npm uninstall -g create-react-app

1 Like

Hello lasjorg, it does work in incognito and in Firefox and Safari. I click the file for common.js and it goes to a library extension for Chrome . I uninstalled the extension and the error is gone. Thank you for pointing me in the right direction. That was driving me crazy for a good hour lol. Thank You and have a good day.