Create-react-app not working

Hey freecodecamper’s.
I’m a little bit stuck.
I’m learning react currently and I’m trying to complete the projects locally on my machine.
I’ve downloaded node and I have vscode already.
But when I’m trying to do,

npx create-react-app react-tutorial

I get this error

npm ERR! code E410
npm ERR! 410 Gone - GET http://bemobi.mtnonline.com/

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\22963\AppData\Local\npm-cache\_logs\2022-07-16T14_32_56_698Z-debug-0.log

Aborting installation.
  npm install --no-audit --save --save-exact --loglevel error react react-dom react-scripts cra-template has failed.

Deleting generated file... package.json
Deleting react-tutorial/ from C:\Users\22963\Desktop
Done.

I’ve tried researching for the solution on stackoverflow but the solutions I’ve found so far doesn’t work for me.
I really need help guys

Do you have your project on GitHub so we can take a look?

I’ve not yet created a react app. So, I’ve not started working on the project. I’ m finding it hard to set up my react app locally. That’s the issue

“410 Gone - GET http://bemobi.mtnonline.com/” - indicates that it’s trying to access a resource that no longer exists.

Did you install CRA before? According to the docs -

“If you’ve previously installed create-react-app globally via npm install -g create-react-app , we recommend you uninstall the package using npm uninstall -g create-react-app or yarn global remove create-react-app to ensure that npx always uses the latest version.”

Have you tried that?

Seems like an odd error message, not sure why npm would try to connect to that address? It looks like some Nigerian hosting company. Maybe it’s a DNS issue and that page is some type of redirect. You can try a free open DNS provider just to test it.


Did you try what was suggested above?

Which version of node and npm do you have installed?

You can try using Vite instead.

Or jump straight to Next.js and forget about create-react-app (there are some big differences though).

Thank you so much. I used vite and it works. Continue doing the work you do. You guys are amazing. I’ve being stuck on this for hours