EvalError: call to eval() blocked by CSP

I keep getting this error in the console while working on advanced js algorithms. It won’t run any of my code and I don’t know a way around this. Does this have anything to do with the maintenance that took place today?


Same problem in this challenge, even with the default code https://www.freecodecamp.org/learn/javascript-algorithms-and-data-structures/basic-javascript/iterate-with-javascript-do...while-loops

I looked it up and it seems to be an issue related to security and JQuery, so your code isn’t the issue. Probably a system issue in the FCC backend?

1 Like

Same issue here.
It happens even in the very first js lesson with no input.

I am getting this error too in all lessons. It detects errors on my code, but I am unable to submit any lessons, as if it does not receive the output and considers wrong.

Hey guys. New to FCC but I started 6 challenges in the JS certification and was doing well, and then had the same issue. Unfortunately I can’t progress further due to EvalError: call to eval() blocked by CSP

and I know that my answer isn’t wrong. The var sum = 10 + 10;

Chrome still works.
Had the issue starting of today on all exercises in firefox.


Thanks @michaelsndr I’ll download chrome and get to work


Good to know that you can go on on other browser, still here’s an screenshot of what I’m getting in the firefox console

Not exactly the same error message, but I think the message depends on the browser. I’m using Edge when solving the JavaScript challenges and the following message appears even with the default code when refreshing the page: “EvalError: Blocked by Content Security Policy”

If any of you gets a solution to this problem please share it with everyone asap. Thanks in advance.

I was getting the same error message on chrome at first but after closing and reopening the browser, it started working like normal. Not really a solution but a quick work around for now.

Tried using Chrome and it works. The catch is that for some reason I can’t use ES6 syntax. The following code should be working (as it did previously when using Edge yesterday):

findLongestWord=(str)=>(str.replace(/\w/g,"1").split(" ").sort().pop().length);
findLongestWord("The quick brown fox jumped over the lazy dog");

But the only thing I get in the console is this: “ReferenceError: findLongestWord is not defined”

Had to switch to ES6 to pass the challenge(find longest word in a string is the challenge’s title).

in that way you are storing a function in a variable called findLongestWord that was not defined, the error you are getting is to be expected

Yep, same issue for me, latest firefox dev edition

I have the same error in Firefox, while in Chrome i can’t log in: a server error page appear, refreshing or restarting chrome doesn’t help at all nor deleting cookies. Anyone have this issue?
Thank you!

there is to patient a bit till the servers return to working order, till then some hiccups are expected

I’m having the same problem since yesterday.

I’m also experiencing this issue. I am using the latest Firefox version in Manjaro.

Hi fellow campers!
Just to point out that this issue seems to have been raised on the Github repository for the FCC website

There’s also a blue notification at the top of this page talking about “issues with our learning platform for Safari and Firefox”, hope everyone can see it.
Guess we just have to wait it out :man_shrugging:

1 Like

Firefox works good now, but still i can not login in with Chrome i receive always a bad gateway error. Does not help reloading or hard-reloading and clearing the cache.