Flappy Penguin in the new curriculum: Error?

Tell us what’s happening:
Hey, everyone. In step 1 from the Flappy Penguin project, I can’t seem to pass with the code below, which seems fine to me.

Here’s what I get: " Sorry, your code does not pass. Try again. Hint: You should have two ‘meta’ elements."

I even tried adding the forward slash to the meta tags, but it still didn’t work. Could this be an error in the platform? Am I being daft?

  **Your code so far**
\ file: <!DOCTYPE html>
<html>
<head>
  <meta charset="UTF-8"/>
  <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
  <link href="styles.css" rel="stylesheet" />
  <title>Penguin</title>
</head>
<body>

</body>
</html>
\ file: 

      **Your browser information:**

User Agent is: <code>Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:100.0) Gecko/20100101 Firefox/100.0</code>

**Challenge:**  Step 1

**Link to the challenge:**
https://www.freecodecamp.org/learn/2022/responsive-web-design/learn-css-transforms-by-building-a-penguin/step-1

I’m not sure if \ file: <!DOCTYPE html> is how you wrote it, or if the \file: is just residual from the way the code was copied over.

Asside from that, I copied your code (without the \file: part). The only test it seemed to fail was the link tag needing the type attribute. I was able to submit it without it complaining about your meta tags at all.

1 Like

Thanks for the reply, kinome79.

That \ file: bit was included automatically in my post here.

I was curious after your report and tried to submit the same code via Chrome—and it worked. I got the error message pointing to the “type” attribute and, after I added this, it was accepted.

In the beta version of RWD I was using Firefox without any problems, but this seems to have been the problem here. Will use Chrome from now on.

Thanks again!