Git push origin master

Git push origin master
0

#1

I am currently attempting to complete the “remote control” section of Save your Code Revisions Forever with Git. I have been trying for 2 days now. I cannot for the life of me get past this bit. The problem is I go through all the steps, and then I reach the part where I’m suppose to “git push origin master” in the cloud9. Everytime I get the message
Username for ‘htps://github.com’: Myusername. I put in my username, and then the next thing that pops up is
Password for 'htps://Myusername@github.com. But it won’t let me type anything there! I’ve tried typing it thinking it might be that it is reading what I type, but not letting me see it, but still I get this message:

remote: Invalid username or password.
fatal: Authentication failed for ‘htps://github.com/Myusername/hello-world.git/’

This is very frustrating. I really would appreciate any help. Am I just missing something obvious?

I have also tried using github for the desktop, with the same results.

Please help!

I took out the second T from the links so that the forums won’t recognize them as links, because it said I can’t have more than 2 links.


#2

Password typing on the command line is invisible to stop prying eyes seeing your password.

If you get the password right, it should work - just try again.

I’m not able to test this on cloud 9 myself, but if cloud 9 didn’t allow github pushes, no developer would use it, so I doubt it’s a problem on their end.


#3

Got it. I’ll give it another shot. Maybe I’ve just been getting my password wrong. Thanks!


#4

No worries, let us know if it doesn’t work. If you still have trouble I’ll fire up a c9 instance later to test it out.

Update: just tested it and it does work on C9.


#5

Okay. That worked. I had to reset my github password, because I screwed something up there, but that worked. Thanks!