Github publishing web pages

Hello, I am trying to publish this simple webpage to github. The site itself runs, but all images are broken. The images show when I run the task in visual studio, so I am not sure what is going on. I had someone try to help me with several pull requests, but that ended up getting things out of control. The project can be found at

It seems like setting the homepage property in package.json fixes the problem for most people. I see that you did indeed set homepage, have you also rebuilt and redeployed your project after making that change?

In the tutorials I found that they did not have a slash at the end of homepage. I don’t know if this matters, but you can always try it:

...
"homepage": "https://cb-biggz.github.io/second"
...
1 Like

No luck. I inspected the page, and all images came back as 404. I have tried different paths for the images, but nothing seems to work

Hmm…maybe you can try process.env.PUBLIC_URL

Not sure what you are currently trying, but when I go to your page (Getting Started with Create React App | second) it shows this standard theme:

Is your gh-pages branch set as source for your site?

Also, I see that you did remove the trailing slash in homepage, but your gh-pages branch was not updated after that change. Did you redeploy?

It should be running now. It only started working after I added the slash back

Okay, so what have you tried exactly? I just cloned your repository, removed the trailing slash and ran deploy. The images are working fine for me:

Code: GitHub - BenGitter/second
GitHub page: React App

1 Like

Sorry, I got caught up in personal stuff that I forgot I had a question here. Thank you, it did work after I ran deploy again

1 Like