GitHub SSH keys

GitHub SSH keys
0.0 0

#1

I am currently working on a react app and I figured it was time to commit. When i was trying to push to github, i was getting this error

Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

I tried to make a new SSH key but that didn’t work, and I currently don’t have any SSH keys in my github profile. If anyone could provide me with a step by step process on how to fix this error so I can push my work to github, that would be appreciated.

Cheers


#2

What’s your system? The same error hit me few times and at the end it was keyring fault.
Anyway, here some solved topic:
SO - GitHub error message
SO - Cannot push to git repository using bitbucket
AskUbuntu - Ubuntu 16.04 ssh: sign_and_send_pubkey: signing failed: agent refused operation ( check all the answers, not just the accepted one)


#4

You can follow the below link to create a ssh key and add it in github profile

**
https://help.github.com/enterprise/2.13/user/articles/generating-a-new-ssh-key-and-adding-it-to-the-ssh-agent/
**


#5

problem was resolved, thanks all!