Glitch links not working/completing challenges

Tell us what’s happening:

Hi all, just started the “Managing Package with Npm” challenges but the introduction link is not working for any challange.
I tried to remove ^ char and to modify server.js and package.js files as per hint, then copying the Live App link from Glitch Share back in Freecodecamp solution field it doesnt get completed.

Can you help me?
Thanks
Regards
Fiilppo

Your code so far

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36.

Challenge: How to Use package.json, the Core of Any Node.js Project or npm Package

Link to the challenge:

Hello!

We would need a link to your glitch or another way to see your code in order to help debug this issue. :slight_smile:

Hi, please find below the link to Glitch Live app I was testing

https://ing-pippo-0.glitch.me

Thanks!
Filippo

Hello there,

Your code passes for me. Perhaps try a different browser…

Hope this helps

I tried both Chrome and Safari (working on Mac) but none of them got me completed.

The following message is printed:
// running tests package.json should have a valid “author” key // tests completed

package.json should have a valid “author” key

I will repeat this, just to make sure we can get this resolved:

  1. Ensure you are pasting the Live Preview link.
  2. Have the Live Preview open in your browser, before and during submitting the tests, so that you can be sure Glitch has woken the app up.

Hope this helps

Here’s a gif of what @Sky020 is saying


Then paste it in the input test.

GIF is super nice!
Indeed i’m pasting that link to freecodecomp challenge.

https://ing-pippo-0.glitch.me

However it doest get completed. Moreover, if pasted in browser the same link doest work, is this expected?

Thanks all

Hey @ingpippo87, I tried your link myself, and it worked. At this point, i don’t really know what’s wrong.


if you’re wondering , it won’t submit my response until i pressed submit. It won’t submit your work as mine.