Help. react didnt work in codepen

hey guys, i cant find solution for this, i already link the react and reactDOM. but the editor still a blank page and cdn for test suite keep telling me im failed

here the pen : https://codepen.io/Haikalmulop/pen/xxXBZgJ

anyone know whats going on?

ReactDOM.render(, document.getElementById(“app”));

this is looking for an element with the id of “app”

In your html you don’t have an element with the id of app

i’ve tried it, but still didnt do anything :sob:

first thing first, you are missing the closing quote of the initialState string, so fix that, then let see what changes

Hi @haikalmulop !

Welcome to the forum!

As mentioned, everything is in a template string right now.
But the best way for you to debug this would be to comment out most of your code except for the h1.
Make sure that renders on the page correctly.
Then slowly add in more pieces of the jsx.
Then slowly add in more pieces of the other code.
Once you hit the point where the page breaks, then you have identified the problem and will be able to fix it.

okey i found the problem, its because the marked i tried to parse down. i didnt parse it correctly

thank you