How can I deploy my portfolio website to netlify please help

I am unable to deploy my portfolio site to netlify, I am trying to follow these instructions:

ON the netlify website here is the support thread that deals with this:

I am recieving the error page not found:

here are my deployment settings:

Ive also tried with the CLI as per the next set of instructions [here] (same link referenced earlier)(https://www.netlify.com/blog/2020/11/30/how-to-deploy-next.js-sites-to-netlify/) but it did not work

My version of next.js is

    "next": "^7.0.3",

On the netlify website, the page that references this is:

someone commented that a common cause is not specifying the correct folder to publish to:

the next.js builds to the .next folder as per their website:

but that .next folder is specified in the .gitignore so its not in the github repositiory.

What are the settings I need to set in order to fix this?

thank you all help appreciated.

Ive also tried to deploy with vercel but got this:

Cloning github.com/KravMaguy/nextjs-starter-dimension (Branch: master, Commit: 54b1b6f)
00:36:21	Cloning completed in 1237ms
00:36:21	Analyzing source code...
00:36:22	Installing build runtime...
00:36:22	Build runtime installed: 499.203ms
00:36:23	Looking up build cache...
00:36:23	Build cache not found
00:36:24	Installing dependencies...
00:36:24	yarn install v1.22.4
00:36:24	info No lockfile found.
00:36:24	[1/4] Resolving packages...
00:36:25	warning babel-plugin-wrap-in-js > babel-template > babel-runtime > core-js@2.6.12: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
00:36:25	warning next > @babel/runtime-corejs2 > core-js@2.6.12: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
00:36:26	warning next > webpack > watchpack > watchpack-chokidar2 > chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
00:36:26	warning next > webpack > watchpack > watchpack-chokidar2 > chokidar > fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
00:36:26	warning next > webpack > micromatch > snapdragon > source-map-resolve > resolve-url@0.2.1: https://github.com/lydell/resolve-url#deprecated
00:36:26	warning next > webpack > micromatch > snapdragon > source-map-resolve > urix@0.1.0: Please see https://github.com/lydell/urix#deprecated
00:36:27	warning node-sass > request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
00:36:27	warning node-sass > node-gyp > request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
00:36:27	warning node-sass > request > har-validator@5.1.5: this library is no longer supported
00:36:28	[2/4] Fetching packages...
00:36:35	info fsevents@2.3.1: The platform "linux" is incompatible with this module.
00:36:35	info "fsevents@2.3.1" is an optional dependency and failed compatibility check. Excluding it from installation.
00:36:35	info fsevents@1.2.13: The platform "linux" is incompatible with this module.
00:36:35	info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation.
00:36:35	[3/4] Linking dependencies...
00:36:35	warning " > sass-loader@7.3.1" has unmet peer dependency "webpack@^3.0.0 || ^4.0.0".
00:36:40	[4/4] Building fresh packages...
00:36:42	success Saved lockfile.
00:36:42	Done in 18.25s.
00:36:42	Running "yarn run build"
00:36:42	yarn run v1.22.4
00:36:42	$ next build
00:36:43	[6:36:43 AM] Compiling client
00:36:43	[6:36:43 AM] Compiling server
00:36:43	> Using external babel configuration
00:36:43	> Location: "/vercel/workpath0/.babelrc"
00:36:46	[6:36:46 AM] Compiled server in 3s
00:36:51	[6:36:51 AM] Compiled client in 8s
00:36:51	Done in 8.59s.
00:36:51	Found next.config.js:
00:36:51	module.exports = function(...args) {
00:36:51	  let original = require('./next.config.__vercel_builder_backup__.js');
00:36:51	  const finalConfig = {};
00:36:51	  const target = { target: 'serverless' };
00:36:51	  if (typeof original === 'function' && original.constructor.name === 'AsyncFunction') {
00:36:51	    // AsyncFunctions will become promises
00:36:51	    original = original(...args);
00:36:51	  }
00:36:51	  if (original instanceof Promise) {
00:36:51	    // Special case for promises, as it's currently not supported
00:36:51	    // and will just error later on
00:36:51	    return original
00:36:51	      .then((orignalConfig) => Object.assign(finalConfig, orignalConfig))
00:36:51	      .then((config) => Object.assign(config, target));
00:36:51	  } else if (typeof original === 'function') {
00:36:51	    Object.assign(finalConfig, original(...args));
00:36:51	  } else if (typeof original === 'object') {
00:36:51	    Object.assign(finalConfig, original);
00:36:51	  }
00:36:51	  Object.assign(finalConfig, target);
00:36:51	  return finalConfig;
00:36:51	}
00:36:51	Error: No serverless pages were built. Learn More: https://err.sh/vercel/vercel/now-next-no-serverless-pages-built
00:36:54	Done with "package.json"

Here are my build and output settings:

Hi

I never use Next before, but what I do is try build it locally first before deploy.
You can see the error in build.