https://replit.com/@MiloLeng/boilerplate-npm-2#package.json

Tell us what’s happening:
Describe your issue in detail here.

Your code so far

Hello, this challenge does not work on replit. When I try to add “author”: “my name” into package.JSON, it throws and error. Also, from your explanation, it is not clear, where should I add this? Into “Repository” object? Into “Main”? Or elswhere? Please help, the instructions are unclear.

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.128 Safari/537.36.

Challenge: How to Use package.json, the Core of Any Node.js Project or npm Package

Link to the challenge:

you need to add a new key-value pair in the package.json file

Here is my solution, I tried different variations, it always throws and error. Also, how should I save it online and submit a link?

{


	"name": "fcc-learn-npm-package-json",
	"dependencies": {
		"express": "^4.14.0"
	},
	"main": "server.js",
	"scripts": {
		"start": "node server.js"
	},
	"repository": {
		"type": "git",
		"url": "https://idontknow/todo.git"
	}
    "author": "Milos Leng"
}

This is the error it gives me now:

package.json: invalid character ‘"’ after object key:value pair

you are missing a comma, it’s an object, you need a comma after each key-value pair, so you need one before "author" too

Thank you very much, sorry, I am such a noob. Sorry for wasting your time.

it should be saved in your replit account, just submit the link to the preview on the right


I’ve edited your post for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

You can also use the “preformatted text” tool in the editor (</>) to add backticks around text.

See this post to find the backtick on your keyboard.
Note: Backticks (`) are not single quotes (’).

1 Like

Sorry again, but I do not see any option to save my file. I can only run it, but there is not a “save” option…

I tried to submit these 2 links:
1: https://boilerplate-npm-2.miloleng.repl.co
2: https://replit.com/@MiloLeng/boilerplate-npm-2#package.json

But I get an error at ffc.com that t does not include “author” key

please see the screen below:

I’m getting the “author” error as well. Can’t figured this one out.

Hi @jgl2j !

This post hasn’t been active for 5 months.

Please create a new post sharing your code and the issue you are experiencing.

Thanks!