ID doesnt seem to be working in codepen

Im very new to this so I’ve probably made a very basic error but the id’s on my codepen dont seem to be working at all. In my css I have written:

 #user { 
color: yellow

and in my HTML i have written:

<li id="user" >Renationalsing the railways </li>

It would be useful for someone to point out the stupid error that I’m making?

Don’t forget your semicolon! That burns a lot of people. :grin:

Cheers. I’ve changed that but still no luck.

My other ids are doing the same not just that one, I don’t know if that makes any difference?

can we see your code, html and css, maybe codepen link ?


You can try resetting. I’ve had a couple of problems where my code was actually correct (Surprise!), and I didn’t pass the test. Resetting sometimes helps.

You can try pasting your code in for everyone to see. I’m online, so I’ll take a look at it.

I cleaned up your code.
You need to use triple backticks to post code to the forum.
See this post for details.

thanks guys, worked out that I just hadn’t closed an earlier id properly which was screwing up all the rest. Very rookie error. Thanks for the help though.