I'm getting crushed by this Google font issue

(this isn’t the lobster font one)

I’ve tried everything I could think of. The copy paste link tag that google provides, the copy paste @import style. I’ve tried a different google font. No go. I tried experimenting with the URL, like changing CSS2 to CSS, removing the ‘&display=swap’ part of the URL…

Here is one set up that should have worked as far as I can tell:

  <head>

    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-value=1.0">
    <title>The title of the project</title>
    <link rel="stylesheet" href="styles.css" hre=>

  </head>
@import url('https://fonts.googleapis.com/css2?family=Montserrat&display=swap');

*,
::before,
::after {
  margin: 0;
  padding: 0;
}

html {
  box-sizing: border-box;
  font-size: 62.5%;
}

body {
  background-color: #121a2e;
  font-family: 'Montserrat', sans-serif;
  color: white;
}

Hey! Can you add a link to your challange so its easier for others to help you?

Also, I’m not sure because i don’t have your code but it looks like you have a typo at the end of the link tag which might be causing this issue.

I made that change now, although that wasn’t the thing stopping it. Actually, I just fixed it while trying to figure out how to link my specific project to you (the URL in my browser seems generic, so I assumed I had to find a button for a sharable link). I accidentally refreshed project’s tab and it work lol.

So I guess the api call won’t automatically update in the project preview like I assumed it would.

1 Like