Keyboard not working

Keyboard not working
0

#1

Tell us what’s happening:
I am using the amazon fire 7, and I am using the freecodecamp app the playstore. Every time I type in the text editor the delete button won’t work, and instead of deleting it copies the text. I have tried it in other browsers and keyboards but still nothing. Please if anyone can help that would be amazing.

Your code so far


// Setup
var a;
vavara;

a;

ara;

a;

vvr b = 2;


;


 2;


;










rrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr b = 2;

// Only change code below this line

Your browser information:

User Agent is: Mozilla/5.0 (Linux; Android 5.1.1; KFDOWI Build/LVY48F; wv) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/59.0.3071.125 Safari/537.36.

Link to the challenge:
https://learn.freecodecamp.org/javascript-algorithms-and-data-structures/basic-javascript/storing-values-with-the-assignment-operator


#2

Thing 1: I’m pretty sure that the FCC app you found is just someone redirecting you to the website and possibly also showing you ads or getting information from your device. It’s not made by FCC.
Thing 2: It sounds like this is specifically something weird about the Fire’s virtual keyboard. When you say “other keyboards” I assume that you mean that you have tried different keyboard apps rather than using an external keyboard?

I have an old Fire at home that I’ll charge up and see if I can reproduce your issue.


#3

Try asking on amazon Fire support. Can you highlight and over-type what is wrong?


#4

It does in fact appear to be a problem with the Fire’s virtual keyboard. I wasn’t able to delete with it either, but when I plugged in a real keyboard it worked normally.


#5

(taken from the README for the text editor FCC uses)

You’re likely to have issues with virtual keyboards. I can’t use any FCC challenge pages (same behaviour as you’re experiencing) on my phone (new Android) or tablet (old Android), I have to be on a desktop using a physical keyboard. It seems to work fine on my partner’s Surface. I have no idea re Apple tablets. You’re likely to get problems because the editor isn’t built to function on mobile browsers; the virtual keyboard on some OS’, rather than anything else, seems to be the cause of it being completely unusable.

Note the last version of the FCC application had the exact same issue, this isn’t a new thing and is common with JS online text editor libraries


#6

I’ve only attempted to use the editor on a mobile device with a physical keyboard plugged in. The editor does seem to work normally for both Chrome on Oxygen and Silk on Fire with a physical keyboard. I’m not sure how well the tests, etc will work on Silk though and I believe that Fire tablets don’t support any other browser. It does seem to work fine with iPads, Surface, and other tablets that are designed to be desktop replacements. (Although with any Apple mobile device you have to change some of the settings to make it work.)


#7

Thanks for trying it out, and yes I meant other apps that replace the default tablet keyboard. Problem is I don’t have an external keyboard (which I assume is a keyboard specificity for tablets). So I’m left with the question, how do I work around this?


#8

When I say “external keyboard” I just mean a physical keyboard. (As in, one that is external to the tablet.) If you cannot use a physical keyboard and you must use the Fire, then I don’t believe that there is a way to make the backspace “key” work in the editor. As @JohnnyBizzel suggested, you may be able to select text by highlighting it and replace that text as a form of “deleting”.


#9

Thanks for all the advise everyone, seems your all right about many components and basic issues with the fire and mobile support. I have a laptop and use it all the time, just thought it would be easy for me to work on. Thanks again guys


#10

I’ve tried that as well to replace the text but it seems redundant as well. But I think I will have to stick to the laptop, it’s clunky but works