Learn Accessibility by Building a Quiz - Step 66

Tell us what’s happening:

 @media (prefers-reduced-motion: no-preference) {
    * {
      scroll-behavior: smooth;
     }
 }

ISSUE: You should use the * selector.
Already using the " Asterisk",but still it requires *Why this is happening?

WARNING

The challenge seed code and/or your solution exceeded the maximum length we can port over from the challenge.

You will need to take an additional step here so the code you wrote presents in an easy to read format.

Please copy/paste all the editor code showing in the challenge from where you just linked.

Replace these two sentences with your copied code.
Please leave the ``` line above and the ``` line below,
because they allow your code to properly format in the post.

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.3 Safari/605.1.15

Challenge: Learn Accessibility by Building a Quiz - Step 66

Link to the challenge:

I’ve edited your code for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

You can also use the “preformatted text” tool in the editor (</>) to add backticks around text.

See this post to find the backtick on your keyboard.
Note: Backticks (`) are not single quotes (').

They didn’t ask for a media selector.
Remove the code related to that.

 *  {
      scroll-behavior: smooth;
    }

initially i didn’t used media selector but when i saw other’s problem is solved by using media selector then i used it… if i removes media selector then this is coming " You should give * a scroll-behavior of smooth ."

I’ve edited your code for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

You can also use the “preformatted text” tool in the editor (</>) to add backticks around text.

See this post to find the backtick on your keyboard.
Note: Backticks (`) are not single quotes (').

Your solution as quoted here works from my end. Please try one of the following steps to move forward.

Click on the “Restart Step” button and force a refresh of your page with CTRL + F5 then try to paste the code in again.

or - Try the step in incognito or private mode.

or - Disable any/all extensions that interface with the freeCodeCamp website (such as Dark Mode, Ad Blockers, or Spellcheckers), and set your browser zoom level to 100%. Both of these factors can cause tests to fail erroneously.

or - Ensure your browser is up-to-date or try a different browser.

I hope one of these will work for you.

Thank you for your quick reply.It works perfectly in incognito mode

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.