Learn-bash-and-sql-by-building-a-bike-rental-shop sql server and coderoad problem

3 or 4 days before ı was progressing my lesson.The problem has started after I have completed my database and created bike-shop.sh. first of all when I wrote to code that is 'echo -e"etc", my bike-shop.sh file has deleted by system. then ı have reloaded the page and tried again ı have recreated bike-shop.sh and write again the code. and deleted again. this time ı used softly reset but the result is same.
after 3 or 4 times my files lost. and freezed at ‘coderoad launching’ screen. only launching animation was playing . and additional to this situation there was sql connection error.

 (psql --username=freecodecamp --dbname=postgres
psql: error: connection to server on socket "/var/run/postgresql/.s.PGSQL.5432" failed: No such file or directory
        Is the server running locally and accepting connections on that socket?)

for three days ı have tried to solve this problems. ı have read so many sites and use many codes . (this was instructive) but ı couldn’t solve. ı tried to tell the situation with all details. The question is is there any solve for this situation. Please help me.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.