Learn Bash by Building A Boilerplate - CodeRoad Test Don't Works

Hi, I came back to my home and continue with “Learn Bash by Building a Boilerplate” course and the CodeRoad test don’t run.

When I restart the CodeRoad it works, but in the next step never works again less than restarting CodeRoad (look the img).

How can I resolve this? Thanks.

I find something, after restarting the CodeRoad it works but his next steps run the test OK when I execute the same statement: “ls” (look the img)…
it seems that the CodeRoad freezes if it is not restarted.

So you can’t click continue there and keep going @ginobarloco?

Hmm, also not sure what’s happening with that first image you shared. Typically, I would recommend hitting the reset button, closing the terminal by typing exit into it - and open a new terminal - described here. That would reset things and ensure the terminal has the correct settings. I’ll look into it a little more and see if I can figure anything out.

Hi @moT01 , tks for the help, I solved the problem for the current step.
The new problem is that it freezes in that step to do the test, that is, it runs the first step well and then it doesn’t. The workaround is to run the command that passes the first test:
After rebooting both, the next step was to run the clear command. I ran it and it passed the tests, but when I ran the next step it didn’t, except that when I ran the clear command again, the CodeRoad advanced.
I’ll continue like this until I find a solution to this problem.

So what you are describing is that the instructions don’t match what the test expects? They seem to be off by one. That used come up, but I haven’t seen it in quite a while after applying some fixes. Since you are so early on in the tutorial, I would just start over. You should be able to get back to where you were real quick. There are instructions on how to do that here.