Learn CSS Animation by Building a Ferris Wheel - Step 1

Tell us what’s happening:
My test is failing with the error message, " You should have one self-closing link element." I’ve tried rewriting my code several times with the same results. I do have memory loss from chronic illnesses, so it’s very possible that I’m missing or forgetting something here, but I don’t think so. Can anyone help?

Your code so far

<!-- file: index.html -->
<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="utf-8">
    <title>Ferris Wheel</title>
    <link rel="stylesheet" href="./styles.css">
  </head>
  <body>
    
  </body>
</html>
/* file: styles.css */

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/108.0.0.0 Safari/537.36

Challenge: Learn CSS Animation by Building a Ferris Wheel - Step 1

Link to the challenge:

Try removing the / symbol before styles.css.

1 Like

No, I got the same error.

hmm. Your code looks good. Did you remove the period as well?
Otherwise what does the error say exactly?

I did. It says:
Sorry, your code does not pass. Don’t give up.

Hint

You should have one self-closing link element.

Alright, not sure. Your code is good.
So only thing I can think of is it doesn’t want you to fill out the rel and href attributes yet possibly.
Try leaving them blank while still having the closing >

It still wouldn’t accept it, even after I removed everything from the link element.

Hmmm, wish I could help more but I’m not sure what’s wrong. You can try resetting the lesson and entering it again. Otherwise I will contact someone who helps me when I get stuck like this and see if she can help out.

Nope, it still won’t accept it. I just reset the lesson and rewrote my code. No luck.

Dang,
I just messaged a much more experienced coder than I and sent her a link to this post.
Hopefully she can help figure this out. She is in Canada and it’s a bit late so likely will not be tonight.

But I’ve run into this before, and I have a few incomplete projects, because of problems like this. I usually just go to the next step (it will let you skip on the curriculum page) and then you can still complete the project…

I figured it out. I had extensions causing a problem. I had an ad blocker and a spelling and grammar checker.
I’ve been doing lessons for a while without a problem, so I didn’t think this could be the problem, but it was. I disabled the ad blocker right a way, but it took me some work to find the spellchecker since I wouldn’t have thought that would cause issues.
Now I’ll be getting ready for bed. It’s almost 12:30 AM here and I have church in the morning.

1 Like

Nice!
Good find!
Yeah I’m catching up to you on the course honestly. I’m right behind you.
So I’ll check that too and make sure I don’t have the same problem.