Learn SQL by Building a Student Database: Part 2 - Build a Student Database: Part 2

Tell us what’s happening:
Describe your issue in detail here.
I’m trying to connect to the data base in codeally . I inserted the code (psql --username=freecodecamp --dbname=postgres ) at the terminal but I had the following error as outputs.

Your code so far
codeally@7e76cea9b6c3:~/project$ psql --username=freecodecamp --dbname=postgres
psql: error: connection to server on socket “/var/run/postgresql/.s.PGSQL.5432” failed: No such file or directory
Is the server running locally and accepting connections on that socket?

Your browser information:

User Agent is: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/114.0

Challenge: Learn SQL by Building a Student Database: Part 2 - Build a Student Database: Part 2

Link to the challenge:

psql --username=freecodecamp --dbname=postgres


There is no [space] between --username=freecodecamp and the --dbname=postgres arguments. Make sure each argument is separated by pressing the spacebar between psql , --username=freecodecamp, and --dbname=postgres.

Hope this helps.

thanks for point it out. I already added the space but the same error persisted. I don’t know if it is an issue with codeally or freecodecamp

Were you able to log in? Is this still an issue you are having?

I tried again today and still having the same error

Can you use Chrome? I can’t tell you changing browsers will work but you can try. I just ran the codeally machine and it works for me but I’m using windows/chrome.

Have you tried to troubleshoot using this forum? https://forum.freecodecamp.org/t/running-the-relational-database-curriculum-in-your-browser/500231

Thanks again for the help. I followed the instructions at the bottom of the link you sent. The solution that worked was delete the container at the CodeAlly dashboard. After that I have to start the tutorial from the beginning, but I solved the issue.

1 Like