Make-typography-responsive

Make-typography-responsive
0

#1

Hi there,

Can any one help me,
I need :
Set the width of the h2 tag to 80% of the viewport’s width and the width of the paragraph as 75% of the viewport’s smaller dimension.

Whats wrong with my code?

Your code so far



<style>
  h2 {
    vw: 80vw;
    }
  p { 
    vmin: 75vmin;
      }
</style>

<h2>Importantus Ipsum</h2>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vivamus quis tempus massa. Aenean erat nisl, gravida vel vestibulum cursus, interdum sit amet lectus. Sed sit amet quam nibh. Suspendisse quis tincidunt nulla. In hac habitasse platea dictumst. Ut sit amet pretium nisl. Vivamus vel mi sem. Aenean sit amet consectetur sem. Suspendisse pretium, purus et gravida consequat, nunc ligula ultricies diam, at aliquet velit libero a dui.</p>

Your browser information:

User Agent is: Mozilla/5.0 (Linux; Android 7.0; SM-G928C Build/NRD90M) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.126 Mobile Safari/537.36.

Link to the challenge:


#2

The values are correct, but check your property names.


#3

I tryed several options… Can you tell me the solution because apperantly I missing something.


#4

vw and vmin before the colons should be width.


#5

:slight_smile: Yea, I kinda throw every options until something sticked.

But thank you for the answer.


#6

This was really helpful, thank you! I was having the same problem.


#7

Use This it is working

h2 { width: 80vw; } p { width: 75vmin; }

Importantus Ipsum

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vivamus quis tempus massa. Aenean erat nisl, gravida vel vestibulum cursus, interdum sit amet lectus. Sed sit amet quam nibh. Suspendisse quis tincidunt nulla. In hac habitasse platea dictumst. Ut sit amet pretium nisl. Vivamus vel mi sem. Aenean sit amet consectetur sem. Suspendisse pretium, purus et gravida consequat, nunc ligula ultricies diam, at aliquet velit libero a dui.


#8

Here is where you are making a mistake

h2{
    width: 80vw;
}
p{
   width: 75vmin;
}