Managing Packages with NPM - How to Use package.json, the Core of Any Node.js Project or npm Package - tests won't pass no matter what

Tell us what’s happening:

I’ve added a valid “author”: “First Last”, to the package.json file
I’ve pressed Ctrl + S
I’ve git commit and git push in version control tab on left
I’ve published the repl too.
I pressed play button to make it go live on port 3000.
I’ve refreshed the webpages for both replit AND freeCodeCamp.

Still, when I put my live link in test for freecodecamp, it fails.

(P.S. I’ve also tried the incorrect method of putting replit code repository link in browser which also fails)
(P.P.S loading my live link in browser leads to ERR_SSL_PROTOCOL_ERROR, saw something in server.js that limits origin? No solution for me on google search)

Thank you

Your project link(s)

solution: boilerplate-npm - Replit

Your browser information:

User Agent is: Mozilla/5.0 (X11; CrOS x86_64 14816.131.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36

Challenge: Managing Packages with NPM - How to Use package.json, the Core of Any Node.js Project or npm Package

Link to the challenge:

In your Replit repository, click on ‘open website’ and copy the link from there; looks like that’s the link to your live project.

Thanks, but I don’t see a text that says “open website”.
Closest thing to that is this beside the webview console on the top left:
Screenshot 2022-11-23 6.04.33 PM

and that (above prev comment of mine) ^ leaves me with a new tab open with this:
image

Can you be more specific please?
Thanks!

I don’t know a whole lot about replit (I use Github + Heroku for all my back end projects) but when I tried with the following link it passed the tests: https://boilerplate-npm--davidogbeide.repl.co/

Try restarting with a new Replit, if that doesn’t work use a VPN and restart (the SSL issues often seem location-based). Another option is using a different site like Glitch.

You can always use the URL from the preview iframe. Below is your project iframe URL.

https://09ec72b7-6408-4bf7-b5c1-fdfb9ffcb7ee.id.repl.co

oh, wow: you put npm–davidogbeide
whereas I put npm.davidogbeide
which was what showed up as part of my link… This fixed the problem thanks…

I have literally never seen this typo issue anywhere but for some reason, yours with the extra 2 dashes worked and mine without them didn’t :sweat_smile: It’s amazing how no one else got this problem.
Anyways, many great thanks!

I don’t know man, I was just lucky, I guess. Reading Iasjorg’s post it looks like this is not a rare occurrence. Anyway, glad you were able to get it to work.