Managing Packages with Npm - How to Use package.json, the Core of Any Node.js Project or npm Package

Getting this error in console when I click I've completed this challenge(Ctrl + Enter)

Failed to load https://*********** No ‘Access-Control-Allow-Origin’ header is present on the requested resource. Origin ‘’ is therefore not allowed access. The response had HTTP status code 404.

Can someone help?

Try adding the short link from Share your App url field from glitch that passes the test.

I’ve tried it but it didn’t help !!

same issue
did you solve it

Nope…still facing same issue

It worked with the "Share you App " url for me



I’m stuck with this. Can you post the screenshot of the same ?

First did you cloned the glitch from FCC?
If have cloned your glitch app from FCC and update the package.json and use that share your app URL,
then the test will pass sucessfully.


I am currently experiencing the same issue.
I’ve done everything correctly but I can’t get it to pass.

I have the same issue with this challenge ,did you find the solucion guys?

Just clone the repo from freecodecamp, then using “Share your app”, then paste the link of the project to the solution form, it will pass, I have just passed by doing these step!

  1. It’s simple, clone this project.
  2. Change name

  3. Submit answer

Works fine, thanks !
I was sharing the direct link to the file instead of the application.
Any way to improve the Freecodecamp doc with the screenshots you sent me ?
I’d rather work locally and push to Github though so if you have a clue, I’ll gladly take it too !
Thanks again,

Now it can’t find the “licence” key even though it’s in the file…

You should use the link of the live application. There is a button “Show live”. Then copy the link of the new opened window and put that link.


Hi @trungducng , which repo do we clone?
I never saw any introduction to Glitch prior to this lesson. What’s the link to the repo?

Hi, folks, I think you just need to open your app in browser via shared link of your app to make app working before you submit a challenge with your link.

I am still facing the issue: even though after following instructions form screen shots above. could any help pleas?!/babu-npm-intro?path=package.json:6:23

This is ridiculous. The instructions are horrible. Can’t get it to work. In addition. the ask for help button on the challenge does nothing. There seems to be mass confusion with this challenge. A million threads with no clear answer.