MongoDB and Mongoose - Install and Set Up Mongoose

Tell us what’s happening:
Describe your issue in detail here.
I am facing a problem with mongoose version. When I add the dependency “mongoose”: “~5.4.0” , it gives me an error saying exit status 1. When I change the mongoose version to the latest one the error goes away and it runs fine. Please help as the challenge requires mongoose with version ~5.4.0

Your project link(s)

solution: boilerplate-mongomongoose - Replit

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.5060.134 Safari/537.36

Challenge: MongoDB and Mongoose - Install and Set Up Mongoose

Link to the challenge:

Can you post a screenshot of the full error message showing in the console?

My guess is you did not add a valid string for MONGO_URI as a secret in the replit Secrets section.


When I change mongoose version to ~5.4.0 , this is the error that I get. But when I use ^5.14.x it works fine.
I want to know how can I use 5.4.0 without error because my question on freecodecamp demands to use this version of mongoose.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.