Need help with Build a Product Landing Page

Tell us what’s happening:
I’ve been working on the Build a Product Landing Page challenge at the end of the first certification in FreeCodeCamp. I did everything it said and when I clicked run tests, it says I completed 14/16 user stories. Here are the ones it says I haven’t done.

  • When I click a .nav-link button in the nav element, I am taken to the corresponding section of the landing page.
  • When I click the #submit element, the email is submitted to a static page My nav links work and when I click them I am taken to the respective part of the page and the same thing with my submit button. The submit button works on the actual page. I’m really confused. Thanks in advance for all the help.
    codepen .io/officialsn/pen/ExVwgZq (put some spaces in because i’m not allowed to post links)
    ^Link to my code
    (P.S.) This is my first forum post so if it’s done incorrectly, I apologize.

Your code so far

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.129 Safari/537.36.

Challenge: Build a Product Landing Page

Link to the challenge:

https://codepen.io/officialsn/pen/ExVwgZq

^Link to the code

Hello, try to delete the “.nav-link” classes in <li /> element, and delete the “action” attribute in the submit input element.

The <h1 /> not closed correctly which wrap the “About Us” text, that may cause some errors, too. Please use the analyzing tool to check some other missing parts of your code. (click the angle-down button on the right top corner of HTML area to find tools)

1 Like

Hi. This fixed the .nav-link problem (thank you so much for that) but not the submit button problem. Do you have any other ideas that might work? Thanks again!

The error message of your code is:

The #email element’s name attribute should have a value of “email” : expected ‘user_email’ to equal ‘email’

I think you need to change your #email element’s name to “email”, like: name="email"

1 Like

Thank you so much! You saved me hours of stress. Everything is working now :slightly_smiling_face:

You’re welcome. The error message helped a lot. :wink:

1 Like

nice , was about to try help